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SCAP Compliance Checker

The SCAP Compliance Checker is an automated compliance scanning tool that leverages the

DISA Security Technical Implementation Guidelines (STIGs) and operating system (OS) specific

baselines to analyze and report on the security configuration of an information system. The tool

can be run locally on the host system to be scanned, or scans can be conducted across a network

from any machine on the domain. In either scanning environment, the following requirement

applies: The user conducting the scan must have administrative privileges on the machine to be

scanned. If the machine to be scanned is not hosting the tool, domain-level administrative

privileges (or individual local administrator accounts) are required to remotely scan other systems

on the network.

Obtaining the SCAP Tool

The SCAP Compliance Checker can be obtained in two ways, depending upon the

possession of a DoD PKI token:

PKI enabled:

Navigate to DISA’s Information Assurance Support Environment (IASE)
webpage at the following URL.:
http://iase.disa.mil/stigs/scap/Pages/index.aspx , and scroll to the bottom
section titled “SCAP Tools”.

Identify the appropriate version of the tool that corresponds to the Operating

System that will host the application, and provide your PKI credentials when

prompted to start the download of the ZIP file.

Non-PKI Enabled:

Navigate to the DSS ODAA Business Management System via NCAISS at
the following URL.: https://ncaiss.dss.mil

Log into OBMS using your appropriate credentials
Once logged into OBMS, navigate to the top of the home page and click on
“ODAA Bulletin Board”.

Click on “Headquarters Bulletin Board” under the Headquarters section.


http://iase.disa.mil/stigs/scap/Pages/index.aspx
https://ncaiss.dss.mil/

¢ Inthe Headquarters bulletin board, click on the forum post with the title
corresponding to the SCAP Compliance Checker installer you require (e.g.
“SCAP Compliance Checker Applications — Windows”).

e Download the ZIP file, unarchive, and install the application.

Installing the SCAP Compliance Checker:
Within the ZIP file for each Operating System version of the SCAP Compliance Checker is
an included PDF, instructing the user on the appropriate way to install and configure the
software executable on the host system. The user will need to be logged onto the system as

an Administrator in order for the package to install correctly.

STIG Viewer

The STIG Viewer is a Java-based application that will be used in conjunction with the SCAP
Compliance Checker scan results in order to view the compliance status of the system’s security
settings. The STIG Viewer can also be used in a manual fashion (e.g. without SCAP tool results)
to conduct a manual audit of information system security controls. Use of the viewer does not
require administrator privileges, provided that the required software packages to support Java

applications have been installed on the system.

Obtaining the DISA STIG Viewer (Version 2.4.1)

The DISA STIG Viewer is an unclassified, non-PKI controlled tool that can be accessed and
downloaded on DISA’s IASE website at the following URL.: http://iase.disa.mil/stigs/Pages/stig-
viewing-guidance.aspx

The tool requires no installation, and runs as a Java application from any directory on the host

machine.

Operating System Baselines

The STIG Viewer leverages operating System baselines to generate checklists used for
vulnerability assessments. These baselines are version- specific, so ensure that you download the
appropriate baseline for the operating system you wish to assess. For purposes of viewing scan

results of machines other than the host machine, download the baseline representing the scanned


http://iase.disa.mil/stigs/Pages/stig-viewing-guidance.aspx
http://iase.disa.mil/stigs/Pages/stig-viewing-guidance.aspx

system’s architecture. The baselines are unclassified; non-PKI controlled, and can be downloaded
by navigating to DISA’s IASE website at the following URL.:
http://iase.disa.mil/stigs/os/Pages/index.aspx

Scanning with SCAP CC and STIG Viewer

1. Open the SCAP Compliance Checker Application.
=

Open the SCAP Compliance Checker
by pressing the "Windows" Key and
Typil {

Programs (1)
| SCAP Compliance Checker (SCC) 4.01

Files (67)

|. SCAPSTIG

|1y U_Windows_7_V1R27_STIG_SCAP_1-1_Benchmark
JL SCAP

| 1) U_RedHat_6_VIR10_STIG_SCAP_1-1_Benchmark

|1y U_Windows_10_VLR1_STIG_SCAP_1-1_Benchmark

|1 U_Solaris_10_SPARC_V1R13_STIG_SCAP_1-1_Benchmark

=] unclassified_scap_implementation_guidance

| unclassified_scap_implementation_guidance.pdf

|1 U_Windows_7_VLR27_STIG_SCAP_1-1_Benchmark

£ WIN-MB67SNQGQQT_SCC-4.0.1_2016-05-03_173405_Non-Com...
|| 2016-05-03_173405

£ WIN-MB67SNQGQQT_SCC-4.0.1_2016-05-03_173405_All-Settin...
=] WIN-MB67SNQGQQT_SCC-4.0.1_2016-05-03_173405_XCCDF-R...

7 See more results

[scap x| | Shutdown | » |

7T 6 B o

enuine



http://iase.disa.mil/stigs/os/Pages/index.aspx

2. Select the appropriate baseline for the system that is to be scanned. First, click Edit ->
Content and Options:

B Content and Options

¥ SCAP Analysis
OVAL Analysis
OCLL Analysis

Go to Edit -> Content
_and Opti
the appropri
“baseline for the

©
<

7 Cisco 105 Config File:

Analysis Dutput |Warnings | Errors

system to be scanned.

Perform Analysis

Analyze Selected Computer(s)

Cancel Analysic

<

[©] scap content Enabled: 1 ‘ [©] ovat content Enabled: 0 ‘@ OCIL Content Enabled: 0

3. Next check the box for the appropriate baseline that corresponds to the system being
scanned. Also, be sure to designate the scan profile as “MAC-3 Classified”:

CAPQ  Cantent and Options
File Edif 1
sutect Cd | SCAF Content (QVAL Content | OCIL Content| Output Options | Other Options | $5H Options | Devistions | Thresholds|
@ Loc [ nstall SCAP Content| [Configure Patch Updates
) Singld | SCAP Content - 1 of 52 streams enabled
@) Multi SCAP Content SCAP Version Profile Date Version Path &
© Ciscol U Microsoft_Office Publisher 2010 VIR STIG SCAP 1-1 Benchmark 10 MAC-1_Classified 2015-04-16 1 Content\SCAP_Content\
. [ U_Microsoft_Office_Publisher_2013_V1R2_STIG_SCAP_1-1_Benchmark 10 MAC-1_Classified 2015-07-24 1 Content\SCAP_Content,
Analysis G [ U_Microsoft_Office_Sharepointdesigner 2013 VIRL_STIG_SCAP_1-1 Benchmar 10 MAC-1_Classified 2015-04-13 1 Content\SCAP_Content\
LU Microsoft_ Office System 2010 VIRZ_STIG_SCAP 1-1 Benchmark 10 MAC-1_Classified 2015-04-16 1 Content\SCAP_Content,
[ U_Microsoft_Office_System_2013_VIR2_STIG_SCAP_1-1_Benchmark 10 MAC Classified 2015-07-24 1 Content\SCAP_Content\
] U_Microsoft_Office Visio_2013_VIR1_STIG_SCAP_1-1 Benchmark 10 This is the baseline we 2015-04-13 1 Content\SCAP_Content\
[ U_Microsoft_Office_Word_2010_VIRL_STIG_SCAP_1-1 Benchmark 10 have selected; 2015-04-16 1 Content\SCAP_Content\
LU Microsoft Office Word 2013 VIR STIG SCAP 1-1 Benchmark 10 Windows 7, MAC-3 2015-04-13 1 Content\SCAP_Content,
[ U_Windows2012_and_2012_R2_DC_V2R2_STIG_SCAP_1-1 Benchmark 10 Classified. The 2015-06-16 2 Content\SCAP_Content\
[JU Windows2012_and 2012 R2_MS V2R2 STIG SCAP 1-1_Benchmark 10 Jassification setting 2015-06-26 2 Content\SCAP_Content,
[ U_Windows_2003 DC_VER40_STIG_SCAP_1-1 Benchmark y 2015-06-23 6 Content\SCAP_Content\
U Windows 2003 IS V6R40 STIG SCAP 1-1 Benchmark 1 can be changed by 2015-06-24 & Content\SCAP_Content, I
[ U_Windows_2008_DC_V6R32_STIG_SCAP_1-1_ Benchmark 10 clicking on the value, 2015-06-24 6 Content\SCAP_Content\
U Windows 2008 MS V6R32 STIG_SCAP 1-1 Benchmark o indicated by the blue 2015-06-25 6 Content\SCAP_ Content\
[ U_Windows_2008_R2_DC_V1R18_STIG_SCAP_1-1_Benchmark 10 arrow. 2015-06-25 1 Content\SCAP_Content\
U Windows 2008 R2_MS VIRI8 STIG SCAP 1-1_Benchmark 10 MAC-1_Classified 2015-06-25 1 Content\SCAP_Content,
O u_Windows_7_V1R26_STIG_SCAP_1-1_Benchmark MAC-1_Classified 1: Content\SCAP_Content\ =
 SCAP_1-1_Benchmark MAC-3 Classified 1 Content\SCAP_Cantent\
[ U_Windows _8_snd_8-1_VIR11_STIG_SCAP_1-1_Benchmark MAC-1_Classified 06 1 Content\SCAP_Content,
[ U_Windows_Firewall V1R3_STIG_SCAP_1-1_Benchmark 10 MAC-1_Classified 2015-06-26 1 Content\SCAP_Content\
LU Windows Vists VERAO_STIG_SCAP_1-1_Benchmark 10 MAC-1_Classified 2015-06-25 6 Content\SCAP_Content,
“Right click s row in the list for mare options. Left click  row in the list under "rofile” to change profiles.
4 |: | | All content paths are relative to the installation directory at: CAPROGRA~INSCAPCO~1.1\Resources i :' r

4. Click OK to save the configuration settings.



Initiate the scan of the system as shown below:

File Edit Results Help

Select Computer(s) to Review Perform Analysis

ocal Computer: WIN-MBS7SNQGQQT
< [ter Ansy]

ingle Remote Computer:
() Multiple Remote Computers:

() Cisco 10S Config File:

Analysis Dutput |Warnings | En

We will now click
"Analyze Selected
Computer(s)" to
initiate the scan

<

[©] scap Content Enabled: 1 [©] 0VAL Content Enabled: 0 | [©3] 0L Content Enabiect: 0

Once the scan has completed, view the directory containing the results of the scan by
clicking “Results -> Open Results Directory” as shown below:

Open Logs Directary Go to Results -> "Open Perform Analysis
e Results Directory” to [ Anslyze Seiected Computerts) |

Recent Reports 5 obtain the XCCDF file

used to view the scan Z]

“results in the STIG 5
Viewer.

Generate SCAP Summary Reports Cancel Analysis
Generate Detailed SCAP Reperts
Generate Detailed OVAL Reports

Generate CyberScope Reports

WIN-MB67SNQEQGT: Generating report WIN-MB67SNQGQRRT SCC-4.0.1_2016-07-12_130450 All-Secttings_U_Windows_7_V1R27_STIG.htm
WIN-MB67SNQGQQT: Saved results from 50 of 278 XCCDF rules

WIN-MB67SNQGQQT: Saved results from 100 of 278 XCCDF rules

WIN-MB6TSNQGQRQT: Saved results from 150 of 278 XCCDF rules

WIN-MB67SNQGQQT: Saved results from 200 of 278 XCCDF rules

WIN-MB67SNQGQQT: Saved results from 250 of 278 XCCDF rules

WIN-MB67SNQGQQT: Generating report WIN-MBE7SNQGQRT_SCC-4.0.1_2016-07-12_130450_Non-Compliance U_Windows_7_V1R27_STIG.htm
WIN-MB67SNQGQQT: Saved results from 50 of 278 XCCDF rules

WIN-MB67SNQGQQT: Saved results from 100 of 278 XCCDF rules

WIN-MB67SNQGQQT: Saved results from 150 of 278 XCCDF rules

WIN-MB675NQGQQT: Saved results from 200 of 278 XCCDF rules

WIN-MB6&TSNQGQQT: Saved results from 250 of 278 XCCDF rules

WIN-MB6TSNQGQRQT: Adjusted Score - 72.66% [RED]
WIN-MB6TSNQGQ@T: Original Score — 72.66% [RED]

Total Errors: 0

Total Warnings: 0

Review complete. To view the results, if any, click:
Results -> Open Results Directory

or

Results -> Recent Reports

<

@ SCAP Content Enabled: 1 ‘ @ OVAL Content Enabled: 0 @ OCIL Content Enabled: 0




7. This will open the scan results directory. Take note of the XML file containing “XCCDF”.
This is the scan results file that you will import into the STIG Viewer to analyze the

compliance state of the machine:
" - C=S

X
&5 J=[) » Compuier » LocalDisk (C) » Users » TEST » SCC » Resuis » SCAP » WIN-MBG7SNQGQQT » U Windows 7 VIRZ? » 1 » 2016-07-12.130450 » XML ~ [ 42 ][ searcnirns o]
Organize v Includeinlibrary v Sharewith =  New folder = - 0 @

e Name - Date modified Tipe Size
B Desktop =] WIN-ME67SNQGQQT_SCC-4.0.1_2016-07-12_130450_OVAL- CPE-Results_U_Windows_7_VIR27_STIG JA2/2016 104PM XML Document 12Ke
1§ Downloads =) WIN-MB67SNQGQQT_SCC-4.0.1_2016-07-12_130450_OVAL-Results U_Windows_7_VIR27_STIG 7A2/2016105PM XML Document 2076 Ke
%] Recent Places =) WIN-ME67SNQGQQT_SCC-4.0.1_2016-07-12_130450_OVAL-Variables U_Windows 7_VIRZT_STIG 7A2/2016 105PM XML Document 32Ke
=] WIN-ME67SNQGQQT_SCC-4.0.1_2016-07-12_130450_XCCDF-Results_U_Windows_7_VIR27_STIG 7A2/2016 105PM XML Document 1,48 KE
5 Libraries
B Documents e Dot
& Music Date modified: 7/12/2016 1:05 PM
) Pictures
B8 videos

Navigate down
through the directory
to locate your scan

@ Network results. Note the path
in windows explorer.
This is the default

8 Computer

location where scan
results are saved.

' 4 items

8. Open the STIG Viewer application.

9. Once the STIG Viewer application is running, import the appropriate STIG baseline
previously downloaded in Section 3. First, click “File -> Import STIG”:

e Checklist ~ Options  Help
- After opening the STIG
= | Viewer application, Val ID Rule Name +
I import the
w Name appropriate STIG

baseline for the
system being
assessed.

No content in table

Ne content in table

Profile: | No Profile -

~ Filter Options

CATI| | CATH CATIN

Add
@) Inclusive Filter Exclusive Filter
Remove Filter Remove Al Filters

Showing rule 1 out of 324




10. Next, navigate to the directory where you have stored the downloaded baseline. Select the

ZIP file containing the desired baseline and select “Open”:

=8 e )
.
@uvl . » Computer » Data(D:) » Users » _b Downloads » MNew folder » pel |
Organize v Include in library + Share with » Burn New folder =~ B @
-
> Favorites MName Date modified Type Size
=
1) SCC_401_rhel 86 64 2/4/201610:21 AM  Compressed (zipp.. 84,806 KB
> [ Libraries 14 SCC 411 macosx x86 64 /6/2017 9:37 AM Compressed (zipp... 85,560 KB
1) SCC 411 solaris_i386 2/6/2017 %44 AM  Compressed (zipp.. 112,808 KB
© /% Computer 1) SCC_41.1_Windows 2/6/2017819AM  Compressed (zipp.. 103,381 KB
1) U_Windows_7_V1R23_STIG 1 016 1:36 PM  Compressed (zipp... 485 KB
> €l Network 1) U_Windows_7_VIR24_STIG 2/7/2017 10:20 AM - Compressed (zipp... 431 KB
l & items

11. Create a checklist from the STIG baseline you just selected by navigating to the top bar and
clicking “Checklist -> Create Checklist — Selected STIG(s)”:

= DISA STIG Viewer: 2.
_—

Options  Help
STIG Explorer Open Checklist from File
MRILE Import v1.2 Checklist VCreate a checklist Rule Name EaGneallamaion
STIGS. Be sure that  tdown Button Windows 7 Security Technical Implementation
| Windows 7 Secunity Technical Implementation e = ide == . .
Vitea the checkbox for the n pagefile Guide :: Release: 27 Benchmark Date: 23 Oct 2015
Rule Title: Systems must be at supported service pack (SP]
V-1085 STIG benchmark you  media devices. Witle: Sy pp pack (SP)
V-1089 wish to use is checked ¢ pisplay —
indi d by th ¥ Discussion
V-1090 (as indicated by the logon credentials
blue arrow). . % Systems at unsupported service packs or releases will not
WA g hares arsnat re=ticted receive security updates for new vulnerabilities and leaves
V-1097 Bad Logon Attempts them subject to exploitation. Systems must be maintained ata
V-1098 Bad Logon Counter Reset service pack level supported by the vendor with new security
V-1099 Lockout Duration AT
V-1102 User Right - Act as part of OS Update the system to a supported service pack.
Profile: | No Profil V-1104 Maximum Password Age _
gl T - . Application of new service packs should be thoroughly tested
o110 Minimum Password Age before deploying in a preduction environment.
¥ Filter Options V-1107 Password Unigueness - ol
V-1113 Disable Guest Account
CATI[] CATII [_] CATII s CCl: €C1-000366
LEREE] Rename Built-in Guest Account The organization implements the security configuration
Add V-1115 Rename Built-in Administrator Acc... settings.
@ Inclusive Filter | Exclusive Filter V-1136 Forcibly Disconnect when Logon H... NIST SP 800-53 : CM-6 b
V-1141 Unencrypted Password is Sent to S... Rabiliancals
V-1145 Disable Automatic Logon 1A Controls:
V-1150 Microsoft Strong Passwaord Filtering VIvM:1
Remove Filter || Remove All Fiters s S ETR—
Showing rule 1 out of 278 Third Party Tools:




12. Import the SCAP Compliance Checker XCCDF scan results file from Step 7. To do this,
click on “Import -> XCCDF Results File™:

¥ Totals

Overall Totals | CATI| CATII || CATII

Open: 0
Mot a Finding: 0

Not Reviewed

» Target Data
» STIGs
v Technology Area

Select Technology Area:

Not Reviewed:
Not Applicable:

[ Windows 05

» Filter Options

Import the XCCDF
Results File from the
Rule Name
SCAP Compliance
Unsupported S...
Checker scan
Display Shutdo...

conducted earlier.

Clear System P...

Not &ppidistje

NR  V-1085 Removable me...
NR V-1089 Legal Notice Di...
NR  V-1090 Caching of log...
NR  V-1093 Anonymaus sh...
NR V-1097 Bad Logon Att...

NR  V-1098 Bad Logen Co...

NR  V-1099 Lockout Durati...
NR  V-1102 User Right - Ac...
NR  V-1104 Maximum Pass...
NR  V-1105 Minimum Pass...
NR V-1107 Passward Unig...
NR  V-1113 Disable Guest ...

NR  V-1114 Rename Built-i...
NR  V-1115 Rename Built-i...
NR V-1136 Forcibly Discon...
NR  V-1141 Unencrypted P...
NR  V-1145 Disable Autom...
NR  V-1150 Microsoft Stro...

Showing rule 1 out of 278

+

¥ General Information

Windows 7 Security Technical Implementation Guide :: Release: 27
Benchmark Date: 23 Oct 2015

Rule Title: Systems must be at supported service pack (SP) or release levels.

Status: (8) Not Review... (_) Op.. () Nota Finding () Not Applicable [ Severity Override ~

¥ Vuln Information
Discussien || Fix Text | CCI | Misc

Systems at unsupported service packs or releases will not receive security updates for new
wvulnerabilities and leaves them subject to exploitation. Systems must be maintained at a service
pack level supported by the vendor with new security updates.

¥ Finding Details

¥ Comments

13. You can now view the results of the SCAP Compliance Checker scan against the STIG
baseline for your operating system:

STIG Explorer | Checklist X

¥ Totals

Overall Totals | CATI| CATIL| CATII

Not a Finding

» Target Data
» STIGs
¥ Technology Area

Select Technology Area:

Windows 0S5

» Filter Options

Not Reviewed:

Open: 4
Not a Finding: 17 Not Applicable:
Total: 21

Mot Applicable

Sta... Vul ID

Annmaniut
You can now view the

results of your SCAP
Compliance Checker

Scan.
NF V-3344

y Acces...

ous

Assist...

Rule Name +

Q Anonymous sh...
NF User Right - Act ...
o LanMan Authe...
NF

NF

mE  al

Limit giank Pass...

NF  V-3347 Internet Informa...
NF | Vv-3379 LAN Manager H...
NF

NF Anonymous

NF User Right -

NF Default Autorun...
NF Restrict Anonym...
NF Create a token ...

NF  V-34974 Always Install wi...
o V-39137 WINGE-000100

Showing rule 1 out of 21

¥ General Information

Windows 7 Security Technical Implementation Guide :: Release: 27
Benchmark Date: 23 Oct 2015

Rule Title: Systems must be at supported service pack (SP) or release levels.

Status: Not Review.. QOp.. @ Nota Finding Not Applicable | Severity Qverride ~

¥ Vuln Infermation
Discussion | Fix Text | CCI | Misc

Systems at unsupported service packs or releases will not receive security updates for new
vulnerabilities and leaves them subject to exploitation. Systems must be maintained at a service
pack level supported by the vendor with new security updates.

v Finding Details

¥ Comments

If you have any questions or concerns, please contact your assigned ISSP, or visit the DSS NAO
RMF website located at the following address: www.dss.mil/rmf



http://www.dss.mil/rmf
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